Commit 9d7816db by Hugo Richard Gomes Vieira

Fixing version.

1 parent a86d050f
......@@ -258,7 +258,7 @@ cmake_installed_version_second_dig=`cmake --version | grep version | awk 'NR ==1
# Verify the first digit
if [[ "$cmake_installed_version_first_dig" == *"."* ]]; then
cmake_installed_version_second_dig=`cmake --version | grep version | awk 'NR ==1{print substr($3,1,2)}'`
cmake_installed_version_first_dig=`cmake --version | grep version | awk 'NR ==1{print substr($3,1,2)}'`
fi
if [[ "$cmake_version_first_dig" == *"."* ]]; then
......@@ -276,7 +276,7 @@ fi
# Checking if the CMake is already installed
echo "Checking if the CMake is already installed..."
if [ "$cmake_installed_version_first_dig" -gt "3" -o "$cmake_version_first_dig" -eq "3" -a "$cmake_installed_version_second_dig" -ge "11" ]; then
if [ "$cmake_installed_version_first_dig" -gt "3" -o "$cmake_installed_version_first_dig" -eq "3" -a "$cmake_installed_version_second_dig" -ge "11" ]; then
echo "CMake already installed!"
elif [ "$cmake_installed_version_first_dig" -lt "3" ]; then
echo "The version of CMake installed is not compatible with terralib!"
......
......@@ -224,7 +224,7 @@ cmake_installed_version_second_dig=`cmake --version | grep version | awk 'NR ==1
# Verify the first digit
if [[ "$cmake_installed_version_first_dig" == *"."* ]]; then
cmake_installed_version_second_dig=`cmake --version | grep version | awk 'NR ==1{print substr($3,1,2)}'`
cmake_installed_version_first_dig=`cmake --version | grep version | awk 'NR ==1{print substr($3,1,2)}'`
fi
if [[ "$cmake_version_first_dig" == *"."* ]]; then
......@@ -242,7 +242,7 @@ fi
# Checking if the CMake is already installed
echo "Checking if the CMake is already installed..."
if [ "$cmake_installed_version_first_dig" -gt "3" -o "$cmake_version_first_dig" -eq "3" -a "$cmake_installed_version_second_dig" -ge "11" ]; then
if [ "$cmake_installed_version_first_dig" -gt "3" -o "$cmake_installed_version_first_dig" -eq "3" -a "$cmake_installed_version_second_dig" -ge "11" ]; then
echo "CMake already installed!"
elif [ "$cmake_installed_version_first_dig" -lt "3" ]; then
echo "The version of CMake installed is not compatible with terralib!"
......
......@@ -224,7 +224,7 @@ cmake_installed_version_second_dig=`cmake --version | grep version | awk 'NR ==1
# Verify the first digit
if [[ "$cmake_installed_version_first_dig" == *"."* ]]; then
cmake_installed_version_second_dig=`cmake --version | grep version | awk 'NR ==1{print substr($3,1,2)}'`
cmake_installed_version_first_dig=`cmake --version | grep version | awk 'NR ==1{print substr($3,1,2)}'`
fi
if [[ "$cmake_version_first_dig" == *"."* ]]; then
......@@ -242,7 +242,7 @@ fi
# Checking if the CMake is already installed
echo "Checking if the CMake is already installed..."
if [ "$cmake_installed_version_first_dig" -gt "3" -o "$cmake_version_first_dig" -eq "3" -a "$cmake_installed_version_second_dig" -ge "11" ]; then
if [ "$cmake_installed_version_first_dig" -gt "3" -o "$cmake_installed_version_first_dig" -eq "3" -a "$cmake_installed_version_second_dig" -ge "11" ]; then
echo "CMake already installed!"
elif [ "$cmake_installed_version_first_dig" -lt "3" ]; then
echo "The version of CMake installed is not compatible with terralib!"
......
Styling with Markdown is supported
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!